[PC-BSD Pbi-dev] Problems building PBI for 10.0

Renato Botelho rbgarga at gmail.com
Wed Feb 5 13:18:03 PST 2014


On 05-02-2014 19:11, Kris Moore wrote:
> On 02/05/2014 15:35, Renato Botelho wrote:
>> I'm attempting to build FreeBSD 10.0 based PBIs and had an error.
>>
>> Here is the pbi.conf I used on test [1], it works fine for FreeBSD 8.3.
>>
>> After some investigation, I noted the following files were missing on
>> /usr/pbi of target system after installation:
>>
>> .ldconfig
>> .mount_nullfs
>> .pbime
>> .pbimount
>> .pbisyscmd
>> .pbisyslisten
>>
>> After manually copy it from builder to target system, it worked, with
>> some warnings:
>>
>> .mount_nullfs: /usr/pbi/.mounts/git-amd64/virtbase/compat: No such file
>> or directory
>> .mount_nullfs: /usr/local/etc/fonts: No such file or directory
>> .mount_nullfs: /usr/local/lib/X11/icons: No such file or directory
>>
>> Is there any obvious mistake I did on pbi.conf?
>>
>> Thanks
>>
>> [1] http://pastebin.com/dfTS73cN
> 
> The pbi.conf file looks right. Wonder why the files were missing in
> /usr/pbi/ though? Have you checked out our source repo and done a "make
> install" on src-sh/pbi-manager on the target system?
> 
> It almost looks like either the builder or the target machine are
> running old copies of pbi-manager.

I ran 'install.sh' on src-sh/pbi-manager and make install on
src-sh/libsh on builder system, it on master branch of up2date git repo.

Files are present on /usr/pbi on builder, but they are not present on
target system after installation.

If you want to take a look on generated pbi, you can get it at [1].

Best regards

[1] http://files.pfsense.org/packages/10/All/git-1.8.5.2-amd64.pbi
-- 
Renato Botelho


More information about the Pbi-dev mailing list