[PC-BSD Pbi-dev] problem with claws-mail PBI

Ken Moore ken at pcbsd.org
Mon Oct 15 10:46:14 PDT 2012


On 10/15/2012 12:51, Gour wrote:
> On Mon, 15 Oct 2012 12:34:01 -0400
> Ken Moore <ken at pcbsd.org> wrote:
>
>
>>> WITH_BOGOFILTER=true WITH_GPGME=true WITH_SPAMASSASSIN=true "
>> My guess is that it has something to do with the OptionsNG framework
>> that was just put in place for the FreeBSD ports. The
>> "WITH_***=[true/false]" setup is still using the old framework for
>> scripting port builds, so something might have gotten mixed up with
>> the up-conversion to the new framework.
> Hmm...let me say (I forgot to mention it in a previous email) that I
> also tried to use WITH_***=yes with the same result.
>
> Moreover, it's puzzling that Bogofilter plugin is built, while the
> other two referenced in the same line are not?

I just finished talking to Kris about this, and it looks like we will 
need to do a mass-change of how the PBI_MAKEOPTS variable is setup, 
specifically because of the change to OptionsNG for ports (the 
conversions are no longer working).

It looks like the new format for OptionsNG is this:
Old Format:  "WITH_X=true WITH_Y=true"
New Format: "<portname>_SET=X Y"

Try changing that line in pbi.conf to the new format and rebuild just to 
make sure:
[code]
PBI_MAKEOPTS="claws-mail_SET=BOGOFILTER GPGME SPAMASSASSIN"
[/code]

I will be making the appropriate changes to EasyPBI here soon as well, 
so that it is fixed for 9.1-RC3 and 9.1-Release.

-- 
~~ Ken Moore ~~
PC-BSD/iXsystems



More information about the Pbi-dev mailing list