[PC-BSD Pbi-dev] New Eclipse

Kris Moore kris at pcbsd.org
Fri Mar 2 10:16:26 PST 2012


On 03/02/2012 12:38, Fabrizio Parrella wrote:
> This is how I fixed the whole (keep in mind that mine is an upgrade,
> not a fresh install, so my workbench has already a lot of things
> already set and updated) - before you even attempt to start it the
> first time:
>  - AS ROOT:
>     - cp /usr/pbi/eclipse-amd64/.sbin/eclipse-devel
> /usr/pbi/eclipse-amd64/.sbin/eclipse
>     - edit /usr/pbi/eclipse-amd64/.sbin/eclipse, line 3 changed to
> "PROGBIN="bin/eclipse" ; export PROGBIN"
>     - changed post-install.sh to "/lib/eclipse/eclipse.ini" instead
> then "/eclipse/eclipse.ini"
>         - (I was able to manually run the post-install.sh thanks to
> the "--checkscript" option)
>
> started as normal user using the icons, all works properly.
>
> Thank you
>
> Fabry
>
I've gone ahead and added those changes, it should be rebuilding in the
next 24 hours, and we can test it :)

> On 03/02/2012 12:29, Fabrizio Parrella wrote:
>> I also noticed that the executable contained in .sbin is called
>> eclipse-devel. Starting that doesn't have any plugins working and the
>> main menu has two eclipse under programming, one with the eclipse
>> purple icon that doesn't work when clicking on it, and one with a
>> wheel that I assume points to eclipse-devel.
>>
>> Fabry 
>
> _______________________________________________
> Pbi-dev mailing list
> Pbi-dev at lists.pcbsd.org
> http://lists.pcbsd.org/mailman/listinfo/pbi-dev


-- 
Kris Moore
PC-BSD Software
iXsystems



More information about the Pbi-dev mailing list