[PC-BSD Pbi-dev] New Eclipse

Fabrizio Parrella fabrizio at bibivu.com
Fri Mar 2 09:09:27 PST 2012


I assume that my system silently automatically downloaded and installed 
the new Eclipse while I was developing, and once finished not only I 
lost the changes that I was making but eclipse stopped completely to work.

I tried to manually download the PBI and install it, but this is what is 
happening:

#pbi_add -r eclipse
Downloading 
ftp://akane.desync.com/pub/pcbsd/PBI/java/eclipse-devel/9/x64/eclipse-3.7.0_4-amd64.pbi
/usr/pbi/.eclipse-3.7.0_4-amd64.pbi.25708     100% of  825 MB 3679 kBps 
00m00s

Verifying Checksum...OK
Extracting to: /usr/pbi/eclipse-amd64
/tmp/.PBI.25708/.PBI-header.25708/post-install.sh: cannot create 
/usr/pbi/eclipse-amd64/eclipse/eclipse.ini: No such file or directory
Installed: Eclipse-3.7.0_4
#


Is there a place where I can find the old eclipse ? shouldn't, even when 
set to autoinstall, at least give a 15 second popup noticed "<PBI> is 
going to be upgraded, please click here if you don't want to upgrade at 
this time<br />The installation will start in [15] seconds".  This will 
avoid the program that you are using to completely shut in the middle of 
your work as well as avoid weird slow downs of the system only because 
it is upgrading a PBI and you are not aware of it.

I blocked all the PBI from automatically update for now, but the problem 
is that I am updated with a broken eclipse and I can't really work until 
is fixed... and the old version took me quite a few hours to make it work.

Any help is greatly appreciated

Thank you

Fabry


More information about the Pbi-dev mailing list