[PC-BSD Pbi-dev] Created PBIs do not work?

Ken Moore ken at pcbsd.org
Wed Jun 20 10:23:10 PDT 2012


On 06/16/2012 01:05, Sam Lin wrote:
> Hi PBI fellows,
>
> I have tried to create two PBIs for scientific application which I 
> would like to use for my work:
>
> 1. math/rkward
> 2. math/sage
>
> These were created with EasyPBI 1.2 on my AMD64 machine. These 
> appeared to be built flawlessly, however they just do not work after I 
> install the PBI products and tried to launch from Kick-off. At first 
> the mouse cursor appears that it's launching the two new applications 
> but then a few seconds later nothing happen with no error message.
>
> Is there anyway that I can investigate what has gone wrong?
>
> Also why is the EasyPBI on AppCafe still remains as ver. 1.0 rather 
> than 1.2?
>
> Regards,
> Sam
>
>
> _______________________________________________
> Pbi-dev mailing list
> Pbi-dev at lists.pcbsd.org
> http://lists.pcbsd.org/mailman/listinfo/pbi-dev

Run your PBI's from the command-line in order to see any error output:
Example: "/usr/pbi/(pbi-name)-(arch)/.sbin/(binary-name)"
This will help you to figure out what is happening in the background. I 
think that sage is just a library collection, so I am not sure that 
there is a GUI component to it (or even a usable binary), but you should 
probably check that.

Also, after numerous requests for the maintainer to update the EasyPBI 
port, I decided to go ahead and update the port myself. I am currently 
in the process of testing my changes and making sure it works, but I am 
hoping to have this finished soon. Once the port update gets committed, 
we can then get a new PBI out in the AppCafe.

-- 
~~ Ken Moore ~~
PC-BSD/iXsystems

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/pbi-dev/attachments/20120620/8befa773/attachment.html>


More information about the Pbi-dev mailing list