[PC-BSD Pbi-dev] multimedia/vlc enable teletext support enable ZVBI in pbi.conf

Ken Moore ken at pcbsd.org
Fri Feb 10 04:34:40 PST 2012


On 02/10/2012 06:46, Hakisho Nukama wrote:
> 2012/2/6 Hakisho Nukama<nukama at googlemail.com>:
>> 2012/1/30 Ken Moore<ken at pcbsd.org>:
>>> On 01/28/2012 16:37, Hakisho Nukama wrote:
>>>
>>> 2012/1/27 Hakisho Nukama<nukama at googlemail.com>:
>>>
>>> After setting up my new Pinnacle 460e DVB-S2 stick with webcamd and vdr
>>> 1.7.22
>>> I was able to get teletext shown over network stream with Windows 7 vlc.
>>>
>>> Inside PCBSD with vlc-1.1.11_1-i386 clicking on Teletext button results in
>>> following message:
>>> No suitable decoder module:
>>> VLC does not support the audio or video format "telx". Unfortunately
>>> there is no way for you to fix this.
>>>
>>> telx is disabled by default at configure time.
>>> But it is incompatible with VBI, which could also decode teletext.
>>>
>>> Enabling telx support with this patch
>>> http://people.freebsd.org/~jsa/share/vlc_telx.diff
>>> does not help either. Vlc doesn't show teletext,
>>> log with telx enabled at http://pastebin.com/JpwyQ0Kn
>>>
>>> But just enabling ZVBI option solves this issue and teletext is shown
>>> as it should.
>>>
>>> Best Regards
>>> Hakisho Nukama
>>>
>>> Attached my pbi.conf.patch of a working pbi-build.
>>>
>>> Best Regards
>>> Hakisho Nukama
>>>
>>>
>>>
>>> _______________________________________________
>>> Pbi-dev mailing list
>>> Pbi-dev at lists.pcbsd.org
>>> http://lists.pcbsd.org/mailman/listinfo/pbi-dev
>>>
>>>
>>> Thanks for the patch!
>>> I have added it to our current PBI module for VLC and triggered a rebuild.
>>>
>>>
>>> --
>>> ~~ Ken Moore ~~
>>> PC-BSD/iXsystems
>>>
>>>
>>> _______________________________________________
>>> Pbi-dev mailing list
>>> Pbi-dev at lists.pcbsd.org
>>> http://lists.pcbsd.org/mailman/listinfo/pbi-dev
>>>
>> Ken, thanks for including it.
>>
>> While my PBI build for vlc defaults to /dev/cd0 inside "Open Disc" dialog,
>> PBI from AppCafe referring to /dev/acd0.
>>
>> /dev/cd0 should be used automatically after OSVERSION 900037
>> WITH_CDROM_DEVICE?=/dev/cd0
>> WITH_DVD_DEVICE?=/dev/cd0
>>
>> On what OSVERSION does building for PBIs occur?
>>
>> Best Regards
>> Hakisho Nukama
> scripts/post-install.sh in
> ftp://ftp.pcbsd.org/pub/pbioutgoing/i386/9/multimedia/vlc/vlc-1.1.13_4-i386.pbi
> ends a if construct with if, not fi.
>
> Best Regards
> Hakisho Nukama
> _______________________________________________
> Pbi-dev mailing list
> Pbi-dev at lists.pcbsd.org
> http://lists.pcbsd.org/mailman/listinfo/pbi-dev

Thanks for spotting that!
I just fixed it in svn.

-- 
~~ Ken Moore ~~
PC-BSD/iXsystems



More information about the Pbi-dev mailing list