[PC-BSD Pbi-dev] PBI module for LibreOffice - with some glitch

Sam Lin semin2006 at gmail.com
Mon Mar 14 22:18:13 PDT 2011


On 15 March 2011 08:00,  <pbi-dev-request at lists.pcbsd.org> wrote:

> Date: Mon, 14 Mar 2011 11:17:56 -0400
> From: Kris Moore <kris at pcbsd.org>
> To: pbi-dev at lists.pcbsd.org
> Subject: Re: [PC-BSD Pbi-dev] PBI module for LibreOffice - with some
>        glitch
> >
> > Sam,
> >
> > I have just finished comparing LibreOffice 3.3.1 and OpenOffice 3.2.1
> > (both downloaded with the software manager). I am unable to reproduce
> > this slowness that you described in LibreOffice. I also verified that
> > both LibreOffice and OpenOffice have nearly identical visual effects and
> > integration within KDE. Whether this is a KDE3 or KDE4 integration I
> > cannot speak to, but it appears to match my desktop theme fairly well
> > without appearing "old".
> >
> > As such, I do not see a reason to remove LibreOffice from pbidir at this
> > time. If you find an error that I
> > can reproduce, I will consider removing the PBI.
> >
> > ~Ken Moore
>
> I've also been running LibreOffice 3.3.1 on the CURRENT snapshots, and
> it seems just fine, no slow-downs that I can think of. Visually it looks
> the same as my regular open-office does.
>
> Is there anything unique to your setup Sam that I could do to try and
> replicate these issues? Do you have any extra port / WM stuff installed?
>
>
> --
> Kris Moore
> PC-BSD Software
> iXsystems
>

Hm... that's really strange. Rumor is that the code base of LibreOffice is
half as much as that in OpenOffice, and also I actually felt when compiling
LibreOffice that it's slimmer than OpenOffice and I cannot see why it's so
sluggish on my system. Even though my laptop is a bit old (AMD Athlon XP-M
2400+, 1024MB RAM, 120GB HD, ATI Radeon Mobile U1), OpenOffice 3.2.1
responds much better than LibreOffice 3.3.1.

I thought it was because I had played around with KDE4 desktop themes on my
8.2 (i386), but trying reinstalling the whole PCBSD system and then
reinstall LibreOffice straight away still gave the same sluggish response.
Tried both "radeon" and "vesa" graphic drivers but did not give any
difference e.g. still gives half-and-incomplete pulldown menu as shown in
the previously attached screenshots.

As for the appearance, it does look a bit close to OpenOffice once I switch
the icons in my LibreOffice from the default "automatic" to "small classic",
although it still does not reflect the style of my current KDE4 theme at
all...

Can you send me some screenshots of your both LibreOffice and OpenOffice and
let me see how it looks like on your system?

Perhaps I should also post this on the forum and see how LibreOffice is
performing on others' systems.

Sam
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pcbsd.org/pipermail/pbi-dev/attachments/20110315/715fa8ad/attachment.html>


More information about the Pbi-dev mailing list