[PC-BSD Pbi-dev] How to build PBI modules that require "updated" jdk?

Kris Moore kris at pcbsd.org
Tue Jan 11 10:03:57 PST 2011


On 01/07/2011 01:57, Sam Lin wrote:
> Unfortunately with the recently downloaded javapack (as of Wed
> 5/Jan/2010), it still says something wrong with java. Once
> editors/omegaT pbi is built, installed and executed, it spat out the
> following error message:
>
> "You need to update your JDK 1.6 to the latest version, or just remove
> the jaxb-*.jar files from the OmegaT /lib dir"
>
> And PCBSD Crash Handler gave the following log:
>
>
> Output logged from stdout
> =========================
>
>
> Output logged from stderr
> =========================
>
> 10476: Info: ===================================================================
> 10476: Info: OmegaT-2.0.5_4 (Fri Jan 07 19:50:15 NZDT 2011)  Locale en_US
> 10476: Info: Java: Sun Microsystems Inc. ver. 1.6.0_03-p4, executed
> from '/usr/Programs/OmegaT/jdk1.6.0/jre' (LOG_STARTUP_INFO)
> 10476: Info: Docking Framework version: 2.1.4
> 10476: Info: Error loading hunspell: Unable to load library
> '/Programs/OmegaT/share/java/omegaT/native/libhunspell.so': Cannot
> open "/Programs/OmegaT/share/java/omegaT/native/libhunspell.so"
> Locale: "en"
>
>
>
>
> Java is really troublesome... :(
>

Yea, java can be a pain :(

Its possible that our java version is simply too old. Do you know if 
omegaT works with the newer openjdk? If so we can probably adjust the 
module to build with that instead of the diablo stuff.

-- 
Kris Moore
PC-BSD Software
iXsystems



More information about the Pbi-dev mailing list