[PC-BSD Pbi-dev] How to build PBI modules that require "updated" jdk?\

Kris Moore kris at pcbsd.org
Tue Jan 4 07:39:14 PST 2011


On Mon, Dec 27, 2010 at 02:30:41PM +1300, Sam Lin wrote:
> Hi -
> 
> I was trying to build pbi module for editors/omegaT, which requires
> java to build and run. As previously advised by Kris I added the
> preportmake.sh which is supposed to solve jdk and license problems
> automatically. Then it ended up with an error saying that I needed to
> download and install java manually.
> 
> I notice that one of the jdk files "tzupdater.zip" in the javapack
> from pcbsd server (ftp://ftp.pcbsd.org/pub/autobuildpkgs/javapack.tbz)
> appears outdated in comparison with that available on Oracle's website
> (tzupdater-1_3_29-2010f.zip cf tzupdater-1_3_34-2010o.zip). I am
> suspecting that it is something like this that is causing the issue.
> Perhaps other files in pcbsd's javapack are also outdated.
> 
> Is it feasible to get the pcbsd autobuild server update javapack as
> soon as new updates are available from Oracle?
> 
> 
> Regards,
> Sam
> 

Sam,

Is this problem fixed with the recent javapack.tbz? I usually try to keep those files up to date, and
if you find that some of them need an update, such as the tzupdater, you can ping me :)

-- 
Kris Moore
PC-BSD Software


More information about the Pbi-dev mailing list