[PC-BSD Pbi-dev] Building eclipse-devel

Dan Rue drue at therub.org
Tue Aug 2 06:08:39 PDT 2011


Cheers, 

I'm attempting to build a PBI for eclipse-devel (eclipse 3.7) in pcbsd
8. It looks like the build server was not able to fetch a jar file on
the last run.

In the meantime I've been trying to build it myself but am running into
the following error.

  ERROR: Your LD_LIBRARY_PATH environment variable is set.  This may 
  produce binaries binaries incorrectly.  Please unset it and
  start your build again. 
  Exiting because of the above error(s). 
  gmake: *** [post-sanity] Error 1
  *** Error code 1
  
  Stop in /usr/ports/java/openjdk6.
  *** Error code 1
  
  Stop in /usr/ports/java/eclipse-devel.
  ERROR: 2.1 Build failed of java/eclipse-devel!!!

I see that createpbi.sh sets LD_LIBRARY_PATH, so I am wondering how the
official build server is getting around this problem.

Thanks!
Dan


More information about the Pbi-dev mailing list