[PC-BSD Pbi-dev] Scilab PBI (Re: pbidir.com "audit" - 7.x/8.x 32/64bits availability)

Sam Lin semin2006 at gmail.com
Sun Oct 10 16:42:48 PDT 2010


Regarding scilab (math/scilab), I have also tried to build it myself
and the building process went flawlessly. However then when I executed
it by typing "scilab" in konsole, it showed:

======== From here ==========

Could not load JVM dynamic library (libjava).
Error: Shared object "libjvm.so" not found, required by "scilab-bin"
If you are using a binary version of Scilab, please report a bug
http://bugzilla.scilab.org/.
If you are using a self-built version of Scilab, update the script
bin/scilab to provide the path to the JVM.
The problem might be related to SELinux. Try to deactivate it.

Scilab cannot open JVM library.

======== ... to here ==========

so it seems something associated with JVM needs to be solved to get it
work properly (which I don't really have clue how to). FYI, I have
attached the (not working) scilab module.


Regards,
Sam


> Message: 3
> Date: Fri, 08 Oct 2010 09:06:17 -0400
> From: Ken Moore <ken at pcbsd.org>
> To: pbi-dev at lists.pcbsd.org
> Subject: Re: [PC-BSD Pbi-dev] pbidir.com "audit" - 7.x/8.x 32/64bits
>        availability

> Thanks for the "audit" Sam. I will be taking a look at some of these
> soon to see if I can clean some of this up. I noticed a couple that were
> removed because of they were perpetually broken (scilab for example),
> and a couple that were removed because they were emulated "hacks" to run
> without the emulator and did not work very well (lure of temptress).

> ~Ken Moore
-------------- next part --------------
A non-text attachment was scrubbed...
Name: scilab.tar.bz2
Type: application/x-bzip2
Size: 16203 bytes
Desc: not available
URL: <http://lists.pcbsd.org/pipermail/pbi-dev/attachments/20101011/dff5106e/attachment.bin>


More information about the Pbi-dev mailing list