[PC-BSD Pbi-dev] trying to build bacula-bat PBI

Silver Salonen silver.salonen at gmail.com
Mon Mar 23 02:03:51 PST 2009


On Wednesday 18 March 2009 16:55:11 Kris Moore wrote:
> Silver Salonen wrote:
> > It seems the PBI got built OK on the server. I tried to install it, but I 
get 
> > an error while trying to do so: "Command '/home/silver/.PBItmp/.pbistart' 
not 
> > found."
> > 
> > Is it because I don't have PC-BSD 7.1beta?
> > 
> > --
> > Silver
> > 
> > On Monday 16 March 2009 16:42:34 Kris Moore wrote:
> >> Sure! If you trigger a build on pbi build server ill check it in the next 
> > day or so when I get back home. Thanks!
> >> ------Original Message------
> >> From: Silver Salonen
> >> Sender: 
> >> To: Kris Moore
> >> Cc: pbi-dev at lists.pcbsd.org
> >> Subject: Re: [PC-BSD Pbi-dev] trying to build bacula-bat PBI
> >> Sent: Mar 13, 2009 8:09 PM
> >>
> >> On Thursday 12 March 2009 23:13:45 Kris Moore wrote:
> >>> That looks like a bug for sure :) I'm in Tokyo at the moment, but get 
> >>> back next week. I'll take a look at this when I get back and figure out 
> >>> whats wrong. I have to issue an update for the PBI Builder soon anyway, 
> >>> lots of other small fixes already :)
> >>>
> >>> Kris
> >> OK, do you want my PBI I tried to build? I can let buildserver to build 
it 
> >> too, I guess? If I change "Active" to smth else in dirstatus, it 
shouldn't 
> > be 
> >> uploaded before testing, right?
> >>
> >> --
> >> Silver
> 
> Thats usually from running the wrong version / PBI from the build 
> server. If you are on 1.5.x, you need this one:
> 
> ftp://ftp.pcbsd.org/pub/pbioutgoing/i386/outgoing/bacula-
bat/BaculaBat2.4.4_1-PV0.pbi
> 
> if you are on 7.x, use this one:
> 
> ftp://ftp.pcbsd.org/pub/pbioutgoing/i386/7/outgoing/bacula-
bat/BaculaBat2.4.4_1-PV0.pbi
> 
> I just tried the 7.x version here, and it installs no problem. It had a 
> few bugs in the PBI.SetupScript.sh though, which I'm fixing now. Just 
> grab the latest out of SVN.

Yes, I tried the wrong version, the correct one installs OK indeed. It also 
works OK, it didn't without your changes :)

But about your changes: wouldn't /PCBSD/local have to be changed to ${BASE} in 
other scripts too? I'd guess it should..

PS. Why not to link the default PBI-folder to the current version of PC-BSD?

--
Silver


More information about the Pbi-dev mailing list