[PC-BSD Pbi-dev] Wine PBI Update 1.1.14 Appears slightly broken

Kris Moore kris at pcbsd.com
Tue Feb 10 12:53:09 PST 2009


Adam Hopstetter wrote:
> Kris Moore wrote:
>> Is this on pcbsd 1 or 7? I've run wine here on 7 and it seemed to run ok.
>>
>>
>> ------Original Message------
>> From: Adam Hopstetter
>> Sender: pbi-dev-bounces at lists.pcbsd.org
>> To: pbi-dev at lists.pcbsd.org
>> Subject: Re: [PC-BSD Pbi-dev] Wine PBI Update 1.1.14 Appears slightly broken
>> Sent: Feb 10, 2009 2:41 PM
>>
>>
>>
>> -------- Original Message --------
>> Subject: 	Re: [PC-BSD Pbi-dev] Wine PBI Update 1.1.14 Appears slightly 
>> broken
>> Date: 	Tue, 10 Feb 2009 14:38:22 -0500
>> From: 	Adam Hopstetter <ahopstetter at gmail.com>
>> To: 	Fabrizio Parrella <fabrizio at bibivu.com>
>> References: 	<4991D350.3000306 at gmail.com> 
>> <020e01c98bb5$43b16350$b001a8c0 at queensboro.com>
>>
>>
>>
>> Fabrizio Parrella wrote:
>>   
>>> did you try to log-out and log back in?
>>>
>>> I had a similar issue in the past, and a log-out log-in solved, 
>>> especially if the binary location is changed.
>>>
>>> Fabry
>>> ----- Original Message ----- From: "Adam Hopstetter" 
>>> <ahopstetter at gmail.com>
>>> To: <pbi-dev at lists.pcbsd.org>
>>> Sent: Tuesday, February 10, 2009 2:19 PM
>>> Subject: [PC-BSD Pbi-dev] Wine PBI Update 1.1.14 Appears slightly broken
>>>
>>>
>>>     
>>>> All,
>>>>    Just received Wine 1.1.14 update ... after such ... at a xterm run
>>>> command 'wine'
>>>>
>>>> output:
>>>>
>>>>
>>>> bash: /usr/local/bin/wine: No such file or directory
>>>>
>>>>
>>>>
>>>> ----
>>>>
>>>> Search and no symlinks for /usr/Programs/bin/wine or /usr/local/bin/wine
>>>>
>>>>
>>>> Also ... I manually created symlinks and now receiving (upon 'wine' in
>>>> xterm) ....
>>>>
>>>> /libexec/ld-elf.so.1: Shared object "libwine.so.1" not found, required
>>>> by "wine"
>>>>
>>>> Thought you should investigate
>>>>
>>>> ---------------
>>>>
>>>> Adam Hopstetter
>>>> _______________________________________________
>>>> Pbi-dev mailing list
>>>> Pbi-dev at lists.pcbsd.org
>>>> http://lists.pcbsd.org/mailman/listinfo/pbi-dev
>>>>
>>>>       
>>>     
>> Fabry,
>>
>>    I did not try log-out/log-in ... however with version 1.1.13 there 
>> was a /usr/local/bin/wine symlink to /usr/Programs/Wine1.1.13/.sbin/wine 
>> ... which disappeared on the 1.1.14 update. Will try log-out, etc. ... 
>> but not optimstic!
>>
>> Adam
>>
>>
>>
>> _______________________________________________
>> Pbi-dev mailing list
>> Pbi-dev at lists.pcbsd.org
>> http://lists.pcbsd.org/mailman/listinfo/pbi-dev
>>
>>
>>
>> --
>> Kris Moore
>> PC-BSD Software
> Kris ... this is on 7.0.2 32-bit Fibo. "PBI" Apps depending on wine such 
> as WinRAR, GoogleEarth, etc. .... appear ok ... however calliing "wine" 
> from an xterm was where I was experiencing the problem. Moreover ... the 
> symlink in /usr/local/bin/wine pointing to 
> /usr/Programs/Wine1.1.XX/.sbin/wine ... has disappeared.
> 
> This may be isolated to my (2) machines ... however I tried updating 
> them twice with the same results. Both are fairly vanilla PC-BSD7.x 
> 32-bit installs.
> 
> Fabry ... log-off/log-in ... does not solve this (but again ... I really 
> didn't expect it to recreate the missing symlinks.)
> 
> So of course I uninstalled Wine1.1.14 ... went to pbiDir and got 1.1.13 
> ... everything ok now!
> 
> ---
> 
> Sincerely,
> 
> Adam Hopstetter
> 
> 

Adam,

Ok, I've figured this out now. Looks like I got a bit carried away when 
I did my cleanup of the wine scripts recently :P

I've fixed it in SVN now, and the PBI is rebuilding right now. We'll get 
the corrected one out right away :)

--
Kris Moore



More information about the Pbi-dev mailing list