[PC-BSD Pbi-dev] opera be busted

Randy Schultz schulra at earlham.edu
Fri May 9 13:55:14 PDT 2008


Heya,

I had a pcbsd box running a fresh install of 1.4.  I was using opera 9.25 on
it to much enjoyment.  I upgraded to 1.5.0 and the new opera(9.26) suddenly
refused to function.  As I had a work-around(using other browsers) I just let
it go, figuring somebody already knew.  ;>  When 1.5.1 came out I upgraded
pcbsd, and upgraded opera to 9.27 however opera is still busted.  I have done
both upgrading from an older version as well as removing opera from the
system(using add/remove software) and re-installed it.

Here are some details that might help:
Dude ? uname -a
FreeBSD tull.lly.earlham.edu 6.3-RELEASE-p1 FreeBSD 6.3-RELEASE-p1 #6: Fri Apr
11 13:03:49 EDT 2008     root at pcbsd:/usr/obj/usr/src/sys/PCBSD  i386

Dude ? which opera
/usr/local/bin/opera

Dude ? ls -l /usr/local/bin/opera
lrwxr-xr-x  1 root  wheel  29 May  9 16:43 /usr/local/bin/opera ->
/Programs/Opera9.27/bin/opera

Dude ? opera
/usr/libexec/ld-elf.so.1: Shared object "libc_r.so.4" not found, required by
"opera"

Dude ? locate libc_r
/usr/lib/libc_r.a
/usr/lib/libc_r.so
/usr/lib/libc_r.so.6
/usr/lib/libc_r_p.a
/usr/local/lib/compat/libc_r.so.5

Dude ? ls -l /usr/lib/libc_r*
-r--r--r--  1 root  wheel  242434 Mar 31 17:13 /usr/lib/libc_r.a
lrwxr-xr-x  1 root  wheel      11 Mar 31 17:13 /usr/lib/libc_r.so ->
libc_r.so.6
-r--r--r--  1 root  wheel  103148 Mar 31 17:13 /usr/lib/libc_r.so.6
-r--r--r--  1 root  wheel  250948 Mar 31 17:13 /usr/lib/libc_r_p.a


I'ld be happy to provide any more info that may help, or to try something for
ya.

Tnx for all the massive amounts of cool work.

--
  Randy    (schulra at earlham.edu)      765.983.1283         <*>

Love with your heart, think with your head;  not the other way around.



More information about the Pbi-dev mailing list