[PC-BSD Pbi-dev] PBI "BUG" :-(

Kris Moore kris at pcbsd.com
Thu Feb 14 16:24:57 PST 2008


Marcel Klinz [PC-BSD.de] wrote:
> Kris Moore schrieb:
>> Marcel Klinz [PC-BSD.de] wrote:
>>> Gonzalo Martinez - Sanjuan Sanchez schrieb:
>>>  
>>>> On Thursday 14 February 2008 10:44:31 pm Marcel Klinz [PC-BSD.de] 
>>>> wrote:
>>>>     
>>>>> same error after a really fresh installing with the cds i 
>>>>> installed the
>>>>> system a few month before.  when i burn an iso i check ery time 
>>>>> the md5.
>>>>> see screenshots
>>>>>
>>>>> maybe you install the german localizied pc-bsd version and install 
>>>>> the
>>>>> sim-im or thunderbird  package from pbibuild.pcbsd.org.
>>>>>
>>>>> cheers
>>>>> marcel
>>>>>
>>>>> Kris Moore schrieb:
>>>>>         
>>>>>> Did you get it reinstalled? We got plenty of new PBIs to play with
>>>>>> testing :)
>>>>>>
>>>>>> As for the hd-image, how did you make it? I normally just make a
>>>>>> tarball of the data I need, and move that over, like this:
>>>>>>
>>>>>> tar cvjf backup.tbz /usr/home/kris
>>>>>>
>>>>>> If you use a 3rd party app, it may not know how the UFS file system
>>>>>> works, and try to backup all the blank data without compression.
>>>>>>               
>>>>> _______________________________________________
>>>>> Pbi-dev mailing list
>>>>> Pbi-dev at lists.pcbsd.org
>>>>> http://lists.pcbsd.org/mailman/listinfo/pbi-dev
>>>>>           
>>>> It really scares...
>>>> I still dont know what to say about this bug.
>>>>     
>>>
>>> maybe it is the problem that i used a 1.4 iso with all the updates 
>>> and not the 1.4.1 with all the update!?
>>> _______________________________________________
>>> Pbi-dev mailing list
>>> Pbi-dev at lists.pcbsd.org
>>> http://lists.pcbsd.org/mailman/listinfo/pbi-dev
>>>
>>>
>>>
>>>
>>>   
>>
>> I'm doing a test load here of 1.4.1 in German. After that, I'll also 
>> try 1.4 then update it, and see if the problem exists. Are you doing 
>> anything else that I would have to change, besides install in german?
>>
>>
> no nothing. purely pure ;-)
>
> !DSPAM:1,47b4d689588513022816921!
>
>

Ahh, Ok, i've been able to duplicate it now. Its not a bug in the PBI 
installer code, rather its a bug in the translation file. The wizard 
titles are being set to "", and its jumping ahead to the last page of 
the install, without installing the app first. I'm going to remove the 
i18n stuff from the PBI auto-build server to prevent this from 
occurring. I'm going to have to only add translations which are 
inspected first, to ensure they work properly.

In the mean-time, go ahead and edit your /PCBSD/LANGS/PCBSDLANG file and 
set the variable to "en". Then you change your KDE lang to english, and 
they should install properly again.

I'll get the lang files removed right now, so that any PBIs generated 
after tonights run will be fine again.



-- 

Kris Moore
PC-BSD Software
http://www.pcbsd.com



More information about the Pbi-dev mailing list