[Pbi-bugs] GoogleEarth

Kris Moore kris at pcbsd.org
Wed Jul 21 05:40:16 PDT 2010


On 07/21/2010 05:22, Johann Hugo wrote:
> I get the following error when I try to run GoogleEarth on PC-BSD 8.1 RC1 -
> x64.
>
> ./googleearth-bin: error while loading shared libraries: libGL.so.1: cannot
> open shared object file: No such file or directory
> Locale: "en"
>
> I get this error on both GoogleEarth version 5.1.3535.3218 and ver 5.2.1.1329
> that I've downloaded from  http://pbibuild64.pcbsd.org/
>
> I've tried to copy /usr/local/lib/libGL.so.1 to /Programs/GoogleEarth/lib/ but
> then I get the following error:
>
> ./googleearth-bin: error while loading shared libraries: libGL.so.1: wrong ELF
> class: ELFCLASS64
>
> Johann
>    

We've fixed this for 8.1-release. If you want to fix it on RC1, you'll 
need to install some additional linux GL ports:

/usr/ports/graphics/linux-f10-dri
/usr/ports/graphics/linux-f10-libGLU


-- 
Kris Moore
PC-BSD Software
iXsystems



More information about the Pbi-bugs mailing list