[PC-BSD Dev] More ZFS odd behaviors

Claudio L. claudio at hpgcc3.org
Mon Jul 8 17:25:35 PDT 2013


Hello,
I found another "easter egg" in the ZFS system.
I have 7 virtual disks in .VDI (Virtualbox) format, that will crash the 
FreeBSD boot loader, even the distribution CD's are unable to boot if 
any of these disks is present on the system.

Why or how this happened is a complete mystery.

While testing the disk manager, I created 7 virtual disks and I added 
them to my VM for testing. I created, destroyed, exported, imported 
pools and what not multiple times.
I rebooted many times in the last month and everything worked perfectly.
Then I upgraded PCBSD to the latest release and rebooted. The boot 
loader stopped giving an error int13, function 42, can't use 64bit LBA.
I inserted the PCBSD install DVD (from June, so it's not the latest), 
and surprise: it can't boot either, same error.
If I remove all the disks except the system disk from the VM, the 
machine works fine (the DVD also boots). If I create 7 new disks, it 
works fine, but if I try to add any one of those VDI's, FreeBSD crashes 
on the boot loader.
I guess during the update, something was written to those 7 disks that 
makes the ZFS code crash (or perhaps it's not on the disks?). All 7 
cause the same effect, but not my system disk, which is also ZFS, and 
was mounted at the same time with the others.

I don't know the exact cause, but I think the ZFS code in the bootloader 
is the one to blame. The problem can be reproduced 100% of the times, I 
can send the .VDI files if there's someone willing to find and fix the 
problem (it's only 5MB each file, since they are basically empty disks).


Claudio




More information about the Dev mailing list