[PC-BSD Dev] [Fwd: Re: virtualbox com object bandaid & qt4 problem?]

Joe Maloney jpm820 at gmail.com
Tue Dec 17 13:32:14 PST 2013


FYI the segfault issue should be fixed as well now.

http://lists.freebsd.org/pipermail/freebsd-emulation/2013-December/011156.html

Joe Maloney

-------- Forwarded Message --------
From: Joe Maloney <jpm820 at gmail.com>
To: dev at lists.pcbsd.org
Subject: Re: virtualbox com object bandaid & qt4 problem?
Date: Sat, 14 Dec 2013 12:52:34 -0600

The good news is that the virtualbox com errors have been fixed in the new port.  I’m still running into segfault issues when running the qt4 app even with a new world and kernel.  I’ve submitted some backtrace info to the freebsd-emulation mailing list starting here.

http://lists.freebsd.org/pipermail/freebsd-emulation/2013-December/011126.html

I’ve also been informed by a FreeBSD user in the freebsd-vbox channel running rc1 that they did not have this problem.  If it still doesn’t work in the next ISO I will do some testing with stock freebsd to see if I can get it to work that way and figure out what the differences are if it does.  Not really a critical issue for me as I don’t really use vbox anymore.  Just wanted to try to help get all the little things fixed.

Joe Maloney


On Dec 8, 2013, at 1:54 PM, Joe Maloney <jpm820 at gmail.com> wrote:

> So I've been looking in the virtualbox cannot create com object error.
> Creating a VirtualBox.xml under /root/./VirtuaBox will fix this.  It
> seems that the executable is no longer creating this file as it should.
> There was a PR created for this one that looks like it hasn't been
> resolved yet.
> 
> http://www.freebsd.org/cgi/query-pr.cgi?pr=183085
> 
> Creating the file is enough to get VBoxManage to work from command line
> and phpvirtualbox to function.  The next problem seems to be the QT
> application segfaulting.  I've noticed some others mentioned having to
> unload env variables such as LANG, some QT4 variables with the
> experimental port.  However I've tried all this in a plain xsession and
> verified that no variables were loading using the env command and no
> dice.  
> 
> I know normally I could debug gtk applications with gdb.  Not sure if
> there may be something similar for qt4.  Really feels like maybe
> something isn't right for launching the qt4 app though as it still
> segfaults there.
> 
> I'm going to give the experimental ports a try next though I don't have
> much hope that will fix.  Although some have reported the experimental
> port works after unloading variables.  In which case that will be
> annoying to have to unload things like LANG and not sure what other
> effects that might have.  Just thought I would pass on what I've found
> so far in case it might help solve.
> 
> Joe Maloney
> 
> 
> 
> 





More information about the Dev mailing list