[PC-BSD Dev] PC-BSD 9.1 issues

Warner Losh imp at bsdimp.com
Fri Dec 28 13:30:25 PST 2012


On Dec 28, 2012, at 2:23 PM, Kris Moore wrote:

> On 12/28/2012 16:10, Warner Losh wrote:
>> I don't think it is a general bge ethernet issue, since I have a machine running 9.1-beta with a bge without issue, but the bge adapter/chip in it are quite.
>> 
>> Warner
>> 
> 
> Any advice on how we can debug this then Warner?

No.  I'm afraid not.  I just checked, and I'm actually running 10.0-current from June on that machine.  Let me see if I try to boot a 9.1 kernel I see the same thing or not.

You may need to talk to the bge driver maintainer to see if there's some light he can shed.

> Fabry, just for kicks, can you use the 9.1 DVD to install FreeBSD 9.1 on
> that box and see if you have the same issues with the bge device? That
> way we can take PC-BSD completely out of the loop here and try to
> isolate the issue.

Excellent place to start.

Warner

>> On Dec 28, 2012, at 11:36 AM, Kris Moore wrote:
>> 
>>> On 12/28/2012 13:04, Fabrizio Parrella wrote:
>>>> To add to the list of issues:
>>>> 
>>>> network bge0 doesn't work any longer.  It was not working on 8.x,
>>>> worked on 9.0, and now is not working again on 9.1.
>>>> 
>>>> The issue is very weird, the OS seems to recognize it as active and
>>>> working, the bottom right icon goes "red" from time to time randomly. 
>>>> When I do an ifconfig everything seems ok.  I checked
>>>> /etc/resolv.conf, /etc/rc.d rebooted the computer but no
>>>> connectivity.  Even tried to change the IP address in case there was a
>>>> conflict.
>>>> 
>>>> My gateway is 192.168.1.1, when I run consecutive
>>>> 
>>>>> ping 192.168.1.1
>>>> I get different errors, from "no route to host" to timeouts.
>>>> 
>>>> 99% of our computers are Otiplex 740, and they all come with the same
>>>> network card.  The ones that have a secondary card in it work without
>>>> problem with that secondary card.
>>>> 
>>>> I believe that as of right now and with those problems I will have to
>>>> stop upgrading the computers, our of the 4 I have tried only one
>>>> worked and one even if now works it needed a lot of command line fixes
>>>> to create new users (it was a brand new installation)
>>>> 
>>>> Maybe I should do what I usually do for windows upgrades and wait for
>>>> a  "service pack" release.... ?
>>>> 
>>>> Fabry
>>>> 
>>> Fabry,
>>> 
>>> I've got the list of bugs you've found here, and will be working to fix
>>> them shortly. As for the networking issue, can you diagnose what type of
>>> bug it is? Driver? Are you certain it isn't a faulty nic? Does ifconfig
>>> show status down, or does the light on the back of nic turn off when it
>>> goes haywire? What makes me think that it may be hardware is that
>>> rebooting didn't seem to fix it :(
>>> 
>>> Can you send me output of "ifconfig bge0" on the system?
>>> 
>>> 
>>>> On 12/26/2012 16:11, Fabrizio Parrella wrote:
>>>>> OK, so far I have experienced a higher speed with the new PC-BSD, the
>>>>> shut-down is almost instantaneous, the boot up is a lot faster, but I
>>>>> have some issues with the network configuration and user creation.
>>>>> 
>>>>> I have already sent an email with some of the issues, but I was
>>>>> thinking that I would summarize them in one emails and add a new one
>>>>> (all of those experienced in 2 different machines and with LXDE as
>>>>> desktop):
>>>>> 
>>>>> - Creating user via the user management doesn't work.  The
>>>>> /home/<user> folder is created and empty, the owner of the folder is
>>>>> root:wheel and not the user itself.  if I chown the folder then I can
>>>>> login with suck user, else I get errors like "folder is full" or
>>>>> "folder does not exists"
>>>>> - manually setting the IP of a network card with netmask
>>>>> "255.255.255.0" gives an error that the netmask should be in range
>>>>> between "0..255".  I set it to 1.1.1.1 and then manually modified in
>>>>> the /etc/rc.conf
>>>>> - changing the hostname completely stops the network from working. I
>>>>> was not able to reach out with dig, but I could ping direct IP
>>>>> address in my internal network.  Wondering if maybe some files needs
>>>>> to be moved or services restarted (I tried to restart the network
>>>>> unsuccessfully).  But anyway, I would suggest a request to reboot
>>>>> when the hostname is changed
>>>>> - Setting the proxy to "http://sub.domain.com" removes everything
>>>>> but the "http" from the configuration
>>>>> - DNS settings were lost after I changed the hostname.
>>>>> - If you try to customize the DNS, then press the "public server",
>>>>> then pressing "OK" or "CANCEL" will cause the network configuration
>>>>> to close.
>>>>> - Missing the configuration for the "NO_PROXY" domains, currently it
>>>>> automatically adds 127.0.0.1 and localhost
>>>>> - Video Card first boot configuration doesn't work.  I tried to
>>>>> install 9.1 on an old DELL 270, there was 9.0 installed and working,
>>>>> I simply formatted and reinstalled.  At first boot I start to get
>>>>> black screen when the video was identified, then starting to get
>>>>> weird errors and some random reboots.  The videocard is an Intel.  I
>>>>> haven't tried to install the 9.0 on it again, but I will probably do
>>>>> it soon.
>>>>> 
>>>>> Thank you
>>>>> 
>>>>> Fabry
>>>> _______________________________________________
>>>> Dev mailing list
>>>> Dev at lists.pcbsd.org
>>>> http://lists.pcbsd.org/mailman/listinfo/dev
>>> 
>>> -- 
>>> Kris Moore
>>> PC-BSD Software
>>> iXsystems
>>> 
>>> _______________________________________________
>>> Dev mailing list
>>> Dev at lists.pcbsd.org
>>> http://lists.pcbsd.org/mailman/listinfo/dev
> 
> 
> -- 
> Kris Moore
> PC-BSD Software
> iXsystems
> 



More information about the Dev mailing list