[PC-BSD Dev] PC-BSD 9.1 issues

Fabrizio Parrella fabrizio at bibivu.com
Wed Dec 26 13:11:11 PST 2012


OK, so far I have experienced a higher speed with the new PC-BSD, the 
shut-down is almost instantaneous, the boot up is a lot faster, but I 
have some issues with the network configuration and user creation.

I have already sent an email with some of the issues, but I was thinking 
that I would summarize them in one emails and add a new one (all of 
those experienced in 2 different machines and with LXDE as desktop):

  - Creating user via the user management doesn't work.  The 
/home/<user> folder is created and empty, the owner of the folder is 
root:wheel and not the user itself.  if I chown the folder then I can 
login with suck user, else I get errors like "folder is full" or "folder 
does not exists"
  - manually setting the IP of a network card with netmask 
"255.255.255.0" gives an error that the netmask should be in range 
between "0..255".  I set it to 1.1.1.1 and then manually modified in the 
/etc/rc.conf
  - changing the hostname completely stops the network from working. I 
was not able to reach out with dig, but I could ping direct IP address 
in my internal network.  Wondering if maybe some files needs to be moved 
or services restarted (I tried to restart the network unsuccessfully).  
But anyway, I would suggest a request to reboot when the hostname is changed
  - Setting the proxy to "http://sub.domain.com" removes everything but 
the "http" from the configuration
  - DNS settings were lost after I changed the hostname.
  - If you try to customize the DNS, then press the "public server", 
then pressing "OK" or "CANCEL" will cause the network configuration to 
close.
  - Missing the configuration for the "NO_PROXY" domains, currently it 
automatically adds 127.0.0.1 and localhost
  - Video Card first boot configuration doesn't work.  I tried to 
install 9.1 on an old DELL 270, there was 9.0 installed and working, I 
simply formatted and reinstalled.  At first boot I start to get black 
screen when the video was identified, then starting to get weird errors 
and some random reboots.  The videocard is an Intel.  I haven't tried to 
install the 9.0 on it again, but I will probably do it soon.

Thank you

Fabry


More information about the Dev mailing list