[PC-BSD Dev] installer comments

Jeremy C. Reed reed at reedmedia.net
Tue Sep 22 11:29:46 PDT 2009


I have been taking many notes as I installed PC-BSD 7.1.1. Here are some 
of these notes: problems and suggestions. I spent a couple hours on 
this. (I have installed FreeBSD hundreds of times.)

1) maybe CD Loader on installer should say "PC-BSD".
It says BTX Loader and FreeBSD. Not very friendly for newbies :)

2) First boot of PCBSD7.1.1-amd64-bootonly.iso hung. I tracked this down 
and to boot I pressed 9 to go to "Escape to loader prompt" and did:

set hint.ppc.0.disabled=1
set hint.sio.0.disabled=1
set hint.sio.1.disabled=1
boot

(ppc is for parellel printer control and and sio is for COM port. I 
don't have these, but kernel output showed them.)

3) Somehow I clicked the mouse somewhere and my PC-BSD Installer
window disappeared. I middle-clicked (both buttons) on background
and use the fluxbox menu to open the iconized window and it came back.
my suggestion is to not allow fluxbox to iconify it. A newbie would have 
no clue what to do.

4) License agreement requires to agree for BSD license (why?). Intel 
firmware license (sets sysctls?) and nvidia driver license but what if 
not needed on my hardware? No good explanation here.

5) Shell choice included: /PCBSD/local/bin/bash, later I saw /usr/PCBSD. 
Is /PCBSD correct on this version? (I never got to check yet.)

6) For file system I chose UFS2 + Journaling. But it still says "Leave 
as default if unsure!" even after choosing an alternative. This is 
misleading, because the dropdown now doesn't tell you the "default".

7) No system components are selected by default. Quick Tips says 
"optional". Well what is already installed? For example, the optional 
unselected component shows "Firefox" and "Opera" but does that mean an 
alternative, like Konqueror, is already going to be installed?

8) Also no long description for each of these available components.
(I didn't select any.)

9) Most operating systems have a BIG WARNING about overwriting hard 
disk, but PC-BSD installer has simple "format" message in the "Tips".

10) CD Mount Error:
Error: Could not load the install disc. Please check that the CD/DVD
is in the drive.
Press OK to try again, or Cancel to reboot the system.

So I am using the "bootonly" iso. The installer should have known that. 
And no way using this menu to get back. The "Select installation choice" 
menu should have set sane default for me or gave me a clear message. (I 
assumed I'd be able to handle this later, so chose defaults first time.) 

So I rebooted (note I had to do the special boot loader steps) and start 
all over).

I chose Install from Network for the Installation Method.

That popped up a new window (when I clicked next)

11) It showed my rel0 ethernet device but not my BCM4318 wireless 
device. (I walked to different floor, to plug in to the ethernet.)

12) Says "Running newfs on ..." maybe make it more newbie 
understandable?

13) Install took a long time. All the steps and downloading and 
installing took about an hour. (That download was over 520 KiB/s.)

14) Setup Complete! But don't recall it ever saying what version of 
PC-BSD.

15) When setup is complete, can't make any changes. Will assume network 
settings are used. Later I saw an icon showing my interface.)

16) Booted to wrong partition! I powercycled and manually chose F2 (F1 
was different operating system). Later, it did boot fine from F2 by 
default.

17) Boot loader numbers didn't match up for install media and new disk 
install. (I accidently pressed "9" to get the loader prompt, but that 
now was "reboot".)

18) First boot showed some failures and a fsck, but went by fast.

19) Detected my Radeon Xpress 200M, but has "vesa". I chose apply for 
default. Why do the X test, if the display is unchanged? (I didn't 
change from the defaults.)

20) First boot was doing something for near a minute without any 
written explanation. There was a hard disk graphic, but I think some 
newbies, may not know what that means.

21) Some Akonadi server startup for over 30 seconds. (I had no idea what 
that is.) Its self test had "an error occurred" with some mysql 
messages, but before I could read it, the window disappeared.

22) Clicked on icons on bottom right. Nothing happened fast. About ten 
seconds later, I got a popup about migrating some database. I didn't 
know what it was and I forgot to write down. Anyways, if this is a clean 
first time boot, it should do that automatically without any popup 
window.

23) I noticed my clock was wrong. I guess no NTP was used.

24) My mouse locked up. I don't know why. I couldn't change consoles. I 
could not ctrl-alt-delete. I power cycled.

24) Restarted (did the set hints... dance). fsck said run manually, and 
it tried to continue. The boot stopped with needing a shell. I pressed 
enter and typed "fsck". It complained about sectors couldn't be read and 
about a journal "CANNOT FIGURE OUT FILE SYSTEM PARTITION".

I tried fsck a few times. Exit and same thing, boot stopped and wants 
shell for manual repair.

I guess that will teach me to try the "Journaling" :)

I will later look at it with smartctl (if available).

Now I see http://forums.pcbsd.org/viewtopic.php?p=75684 and 
http://lists.pcbsd.org/pipermail/testing/2009-March/002021.html
So known problem. Installer should not provide it or should have a major 
warning. (I have experience with GEOM mirror.)

p.s Over the past couple years, I have posted long lists like this here, 
but rarely get any feedback. Nevertheless, I have seen some changes 
related to what I noted in the past. Thanks!






More information about the Dev mailing list